CVE-2018-1124

Published: 17 May 2018

procps-ng before version 3.3.15 is vulnerable to multiple integer overflows leading to a heap corruption in file2strvec function. This allows a privilege escalation for a local attacker who can create entries in procfs by starting processes, which could result in crashes or arbitrary code execution in proc utilities run by other users.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
procps
Launchpad, Ubuntu, Debian
Upstream
Released (3.3.15)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:3.3.12-3ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2:3.3.10-4ubuntu2.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:3.3.9-1ubuntu2.3)
Patches:
Upstream: https://gitlab.com/procps-ng/procps/commit/36c350f07c75aabf747fb833f52a234ae5781b20