Your submission was sent successfully! Close

CVE-2018-10940

Published: 09 May 2018

The cdrom_ioctl_media_changed function in drivers/cdrom/cdrom.c in the Linux kernel before 4.16.6 allows local attackers to use a incorrect bounds check in the CDROM driver CDROM_MEDIA_CHANGED ioctl to read out kernel memory.

From the Ubuntu security team

It was discovered that the cdrom driver in the Linux kernel contained an incorrect bounds check. A local attacker could use this to expose sensitive information (kernel memory).

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-24.26)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by 9de4ee40547fd315d4a0ed1dd15a2fa3559ad707
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1011.11)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1014.14)
linux-azure-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.18.0-1003.3~18.04.1)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1010.10)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.18.0-8.9~18.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1012.12)
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1009.12)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1013.14)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.17~rc3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable