CVE-2018-10852

Published: 26 June 2018

The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
sssd
Launchpad, Ubuntu, Debian
Upstream
Released (1.16.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.2.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.2.2-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.16.1-1ubuntu1.8)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://pagure.io/SSSD/sssd/c/ed90a20a0f0e936eb00d268080716c0384ffb01d