CVE-2018-10840

Published: 16 July 2018

Linux kernel is vulnerable to a heap-based buffer overflow in the fs/ext4/xattr.c:ext4_xattr_set_entry() function. An attacker could exploit this by operating on a mounted crafted ext4 image.

From the Ubuntu security team

Wen Xu discovered that the XFS filesystem implementation in the Linux kernel did not properly validate xattr information. An attacker could use this to construct a malicious xfs image that, when mounted, could cause a denial of service (system crash) or possibly execute arbitrary code.

Priority

Low

CVSS 3 base score: 6.6

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-33.36)
Patches:
Introduced by dec214d00e0d78a08b947d7dccdfdb84407a9f4d
Fixed by 8a2b307c21d4b290e3cbe33f768f194286d07c23
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1020.20)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1022.23)
linux-azure-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.18.0-1003.3~18.04.1)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1018.19)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.18.0-11.12~18.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1020.20)
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1017.20)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1021.23)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.18~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable