CVE-2018-1084

Published: 12 April 2018

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
corosync
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.3-0ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.3.5-3ubuntu2.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/corosync/corosync/commit/fc1d5418533c1faf21616b282c2559bed7d361c4
Upstream: https://github.com/corosync/corosync/commit/50e17ffc736f0052e921c861b6953ba8938e4103
Upstream: https://github.com/corosync/corosync/commit/520a7085b06cb0383a4f92bb0d7fbb748d9e97fe
Upstream: https://github.com/corosync/corosync/commit/08cb2372cd3bd63a910c2618a2cc86cad8885d78
Upstream: https://github.com/corosync/corosync/commit/b25b029fe186bacf089ab8136da58390945eb35c