CVE-2018-1000132

Published: 14 March 2018

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

From the Ubuntu security team

It was discovered that Mercurial incorrectly handled access control. An attacker could possibly use this issue to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
mercurial
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.5.2-0ubuntu2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (3.7.3-1ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.8.2-1ubuntu1.4)