Your submission was sent successfully! Close

CVE-2017-7529

Published: 11 July 2017

Nginx versions since 0.5.6 up to and including 1.13.2 are vulnerable to integer overflow vulnerability in nginx range filter module resulting into leak of potentially sensitive information triggered by specially crafted request.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
nginx
Launchpad, Ubuntu, Debian
precise Does not exist

trusty
Released (1.4.6-1ubuntu3.8)
upstream
Released (1.12.1, 1.13.3)
xenial
Released (1.10.3-0ubuntu0.16.04.2)
yakkety
Released (1.10.1-0ubuntu1.3)
zesty
Released (1.10.3-1ubuntu3.1)
Patches:
upstream: http://nginx.org/download/patch.2017.ranges.txt
upstream: https://trac.nginx.org/nginx/changeset?old=7058&old_path=nginx%2Fsrc&new=1adc6b0d5eaa3bddd6bb1ef7b78b9511d536f14e&new_path=nginx%2Fsrc