CVE-2017-7481

Published: 19 July 2018

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.1.0+dfsg-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.6.1+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.6.1+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.6.1+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.5.1+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.0.0.2-2ubuntu1.3)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/ansible/ansible/commit/ed56f51f185a1ffd7ea57130d260098686fcc7c2