CVE-2017-5334

Published: 11 January 2017

Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
gnutls26
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

gnutls28
Launchpad, Ubuntu, Debian
Upstream
Released (3.5.8-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.6-4ubuntu3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (3.4.10-4ubuntu1.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://gitlab.com/gnutls/gnutls/commit/c5aaa488a3d6df712dc8dff23a049133cab5ec1b
Upstream: https://gitlab.com/gnutls/gnutls/commit/bbfd47d4bb6935b3eddae227deb9f340e2c1a69d (3.3)

Notes

AuthorNote
mdeslaur
looks like this was introduced by
https://gitlab.com/gnutls/gnutls/commit/2bd323f728d75c44a2d7398503178b75e5b63263

References