Your submission was sent successfully! Close

CVE-2017-2518

Published: 22 May 2017

An issue was discovered in certain Apple products. iOS before 10.3.2 is affected. macOS before 10.12.5 is affected. tvOS before 10.2.1 is affected. watchOS before 3.2.2 is affected. The issue involves the "SQLite" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted SQL statement.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
sqlite3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.22.0-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (3.11.0-1ubuntu1.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (3.8.2-1ubuntu2.2+esm1)
Patches:
Upstream: https://www.sqlite.org/src/info/0a98c8d76ac86412