CVE-2017-18269

Published: 18 May 2018

An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(pre 2.21)
glibc
Launchpad, Ubuntu, Debian
Upstream
Released (2.28)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.28-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.28-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.27-3ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.23-0ubuntu11.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=cd66c0e584c6d692bc8347b5e72723d02b8a8ada (master)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=55ad82e45c313454de657931898e974a7a036cad (2.27)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=71d339cb86dc58aa511dd1544dad2c77d075069c (2.26)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=3f949b03473b4ca8b8e69a4e540511dfee39e493 (2.24)