CVE-2017-12587

Published: 06 August 2017

ImageMagick 7.0.6-1 has a large loop vulnerability in the ReadPWPImage function in coders\pwp.c.

Priority

Low

CVSS 3 base score: 8.8

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
Upstream
Released (8:6.9.7.4+dfsg-16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (8:6.8.9.9-7ubuntu5.11)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [8:6.7.7.10-6ubuntu3.11])
Patches:
Upstream: https://github.com/ImageMagick/ImageMagick/commit/d4192df5eb03892089806d52a317cc3101856726

Notes

AuthorNote
mdeslaur
0142-Avoid-unbounded-loop-in-pwp-coder.patch in unstable
0098-Avoid-unbounded-loop-in-pwp-coder.patchin stretch
0276-CVE-2017-12587-Fix-large-loop-vulnerability-in-ReadPWPImage.patch in wheezy

References

Bugs