Your submission was sent successfully! Close

CVE-2017-11546

Published: 31 July 2017

The insert_note_steps function in readmidi.c in TiMidity++ 2.14.0 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted mid file. NOTE: a crash might be relevant when using the --background option.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
timidity
Launchpad, Ubuntu, Debian
Upstream
Released (commit aa05396a01d05, 2.14.0-4)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.14.0-8)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.14.0-8)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.14.0-8)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://sourceforge.net/p/timidity/git/ci/aa05396a01d05a5bc35dd2459f0599eacf0c4f7b/tree/