Your submission was sent successfully! Close

CVE-2017-1000366

Published: 19 June 2017

glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.

From the Ubuntu security team

It was discovered that the GNU C library did not properly handle memory when processing environment variables for setuid programs. A local attacker could use this in combination with another vulnerability to gain administrative privileges.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
precise
Released (2.15-0ubuntu10.20)
trusty
Released (2.19-0ubuntu6.13)
upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist

glibc
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial
Released (2.23-0ubuntu9)
yakkety
Released (2.24-3ubuntu2.2)
zesty
Released (2.24-9ubuntu2.2)