Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-1000071

Published: 17 July 2017

Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.

Notes

AuthorNote
sbeattie
The vulnerability only exists when communicating with a
server affected by another very old vulnerability fixed in 2010.

Priority

Low

Cvss 3 Severity Score

8.1

Score breakdown

Status

Package Release Status
php-cas
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Needed

cosmic Ignored
(end of life)
disco Not vulnerable
(1.3.6-1)
eoan Not vulnerable
(1.3.6-1)
focal Not vulnerable
(1.3.6-1)
groovy Not vulnerable
(1.3.6-1)
hirsute Not vulnerable
(1.3.6-1)
impish Not vulnerable
(1.3.6-1)
jammy Not vulnerable
(1.3.6-1)
kinetic Not vulnerable
(1.3.6-1)
lunar Not vulnerable
(1.3.6-1)
mantic Not vulnerable
(1.3.6-1)
trusty Does not exist
(trusty was needed)
upstream
Released (1.3.6-1, 1.3.5)
xenial Needed

yakkety Ignored
(end of life)
zesty Ignored
(end of life)
Patches:
upstream: https://github.com/apereo/phpCAS/commit/c9ba00327fd0ac8faecc62ce150c1986022856cd

Severity score breakdown

Parameter Value
Base score 8.1
Attack vector Network
Attack complexity High
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H