Your submission was sent successfully! Close

CVE-2016-8734

Published: 30 November 2016

Apache Subversion's mod_dontdothat module and HTTP clients 1.4.0 through 1.8.16, and 1.9.0 through 1.9.4 are vulnerable to a denial-of-service attack caused by exponential XML entity expansion. The attack can cause the targeted process to consume an excessive amount of CPU resources or memory.

From the Ubuntu security team

Florian Weimer discovered that Subversion clients did not properly restrict XML entity expansion when accessing http(s):// URLs. A remote attacker could use this to cause a denial of service.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
subversion
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.5-1, 1.8.17, 1.9.5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.9.5-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.9.5-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.9.5-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.9.3-2ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.8.8-1ubuntu3.3])
Patches:
Upstream: https://subversion.apache.org/security/CVE-2016-8734-advisory.txt

Notes

AuthorNote
mdeslaur
for mod_dontdothat, we don't ship it in binary packages
for clients, we build with serf, so we're vulnerable

References