Your submission was sent successfully! Close

CVE-2016-6318

Published: 07 September 2016

Stack-based buffer overflow in the FascistGecosUser function in lib/fascist.c in cracklib allows local users to cause a denial of service (application crash) or gain privileges via a long GECOS field, involving longbuffer.

Priority

Negligible

CVSS 3 base score: 7.8

Status

Package Release Status
cracklib2
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.9.2-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.9.2-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.9.2-3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.9.2-3)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://bugzilla.redhat.com/attachment.cgi?id=1188599

Notes

AuthorNote
tyhicks
Ubuntu's chfn limits the total GECOS field length to 84 characters
which is well within cracklib2's buffer size of 2048.
libpam-cracklib is not part of the default install so PAM cracklib
support is not enabled in the majority of Ubuntu installs
Ubuntu's /etc/login.defs only allows unprivileged users to set their
room number, work phone, and home phone

References

Bugs