Your submission was sent successfully! Close

CVE-2016-5699

Published: 2 September 2016

CRLF injection vulnerability in the HTTPConnection.putheader function in urllib2 and urllib in CPython (aka Python) before 2.7.10 and 3.x before 3.4.4 allows remote attackers to inject arbitrary HTTP headers via CRLF sequences in a URL.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
python2.7
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(2.7.10~rc1-1)
disco Not vulnerable
(2.7.10~rc1-1)
eoan Not vulnerable
(2.7.10~rc1-1)
focal Not vulnerable
(2.7.10~rc1-1)
groovy Not vulnerable
(2.7.10~rc1-1)
hirsute Not vulnerable
(2.7.10~rc1-1)
impish Not vulnerable
(2.7.10~rc1-1)
jammy Not vulnerable
(2.7.10~rc1-1)
precise
Released (2.7.3-0ubuntu3.9)
trusty
Released (2.7.6-8ubuntu0.3)
upstream
Released (2.7.10~rc1-1)
wily Not vulnerable
(2.7.10~rc1-1)
xenial Not vulnerable
(2.7.10~rc1-1)
yakkety Not vulnerable
(2.7.10~rc1-1)
zesty Not vulnerable
(2.7.10~rc1-1)
Patches:
upstream: https://hg.python.org/cpython/rev/1c45047c5102

python3.2
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was released [3.2.3-0ubuntu3.8])
trusty Does not exist

upstream Needs triage

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

python3.4
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty
Released (3.4.3-1ubuntu1~14.04.5)
upstream Needs triage

wily Ignored
(reached end-of-life)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

Patches:

upstream: https://hg.python.org/cpython/rev/bf3e1c9b80e9
python3.5
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Needs triage

upstream
Released (3.5.0 alpha3)
wily Not vulnerable
(3.5.0-1)
xenial Not vulnerable
(3.5.0-1)
yakkety Not vulnerable
(3.5.0-1)
zesty Not vulnerable
(3.5.0-1)