Your submission was sent successfully! Close

CVE-2016-2120

Published: 01 November 2018

An issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0.1 allowing an authorized user to crash the server by inserting a specially crafted record in a zone under their control then sending a DNS query for that record. The issue is due to an integer overflow when checking if the content of the record matches the expected size, allowing an attacker to cause a read past the buffer boundary.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
pdns
Launchpad, Ubuntu, Debian
Upstream
Released (4.0.2-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.0.2-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.0.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.0.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.0.2-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)