Your submission was sent successfully! Close

CVE-2016-1000341

Published: 04 June 2018

In the Bouncy Castle JCE Provider version 1.55 and earlier DSA signature generation is vulnerable to timing attack. Where timings can be closely observed for the generation of signatures, the lack of blinding in 1.55, or earlier, may allow an attacker to gain information about the signature's k value and ultimately the private value as well.

Priority

Medium

CVSS 3 base score: 5.9

Status

Package Release Status
bouncycastle
Launchpad, Ubuntu, Debian
Upstream
Released (1.56-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.60-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.60-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.60-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.59-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.49+dfsg-2ubuntu0.1])
Patches:
Upstream: https://github.com/bcgit/bc-java/commit/acaac81f96fec91ab45bd0412beaf9c3acd8defa