Your submission was sent successfully! Close

CVE-2016-1000110

Published: 25 July 2016

The CGIHandler class in Python before 2.7.12 does not protect against the HTTP_PROXY variable name clash in a CGI script, which could allow a remote attacker to redirect HTTP requests.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
python2.7
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(2.7.12-3build1)
disco Not vulnerable
(2.7.12-3build1)
eoan Not vulnerable
(2.7.12-3build1)
focal Not vulnerable
(2.7.12-3build1)
groovy Not vulnerable
(2.7.12-3build1)
hirsute Not vulnerable
(2.7.12-3build1)
impish Not vulnerable
(2.7.12-3build1)
jammy Not vulnerable
(2.7.12-3build1)
precise
Released (2.7.3-0ubuntu3.9)
trusty
Released (2.7.6-8ubuntu0.3)
upstream
Released (2.7.12-2)
wily Ignored
(reached end-of-life)
xenial
Released (2.7.12-1ubuntu0~16.04.1)
yakkety Not vulnerable
(2.7.12-3build1)
zesty Not vulnerable
(2.7.12-3build1)
python3.2
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was released [3.2.3-0ubuntu3.8])
trusty Does not exist

upstream Needs triage

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

python3.4
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty
Released (3.4.3-1ubuntu1~14.04.5)
upstream Pending
(3.4.6rc1)
wily Ignored
(reached end-of-life)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

python3.5
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Needs triage

upstream
Released (3.5.2-3)
wily Ignored
(reached end-of-life)
xenial
Released (3.5.2-2ubuntu0~16.04.1)
yakkety Not vulnerable
(3.5.2-3)
zesty Not vulnerable
(3.5.2-3)