Your submission was sent successfully! Close

CVE-2015-8877

Published: 21 May 2016

The gdImageScaleTwoPass function in gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in PHP before 5.6.12, uses inconsistent allocate and free approaches, which allows remote attackers to cause a denial of service (memory consumption) via a crafted call, as demonstrated by a call to the PHP imagescale function.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
Upstream
Released (2.2.0)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.1.1-4ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1.0-3ubuntu0.1)
Patches:
Upstream: https://github.com/libgd/libgd/commit/4751b606fa38edc456d627140898a7ec679fcc24
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.6.12)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses system gd)
php7.0
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses system gd)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
mdeslaur
php uses the system libgd2
tyhicks
2.1.0-3, as shipped in Trusty, has quite a different implementation
for gdImageScaleTwoPass() but I believe it is still affected

References

Bugs