Your submission was sent successfully! Close

CVE-2015-7837

Published: 15 October 2015

The Linux kernel, as used in Red Hat Enterprise Linux 7, kernel-rt, and Enterprise MRG 2 and when booted with UEFI Secure Boot enabled, allows local users to bypass intended securelevel/secureboot restrictions by leveraging improper handling of secure_boot flag across kexec reboot.

From the Ubuntu security team

It was discovered that the Linux kernel did not honor the UEFI secure boot mode when performing a kexec operation. A local attacker could use this to bypass secure boot restrictions.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream Needed

Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by local-2015-7837
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream Needed

This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream Needed

linux-azure
Launchpad, Ubuntu, Debian
Upstream Needed

linux-ec2
Launchpad, Ubuntu, Debian
Upstream Needed

linux-euclid
Launchpad, Ubuntu, Debian
Upstream Needed

linux-flo
Launchpad, Ubuntu, Debian
Upstream Needed

linux-fsl-imx51
Launchpad, Ubuntu, Debian
Upstream Needed

linux-gcp
Launchpad, Ubuntu, Debian
Upstream Needed

linux-gke
Launchpad, Ubuntu, Debian
Upstream Needed

linux-goldfish
Launchpad, Ubuntu, Debian
Upstream Needed

linux-grouper
Launchpad, Ubuntu, Debian
Upstream Needed

linux-hwe
Launchpad, Ubuntu, Debian
Upstream Needed

linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream Needed

linux-kvm
Launchpad, Ubuntu, Debian
Upstream Needed

linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream Needed

linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream Needed

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream Needed

This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream Needed

This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream Needed

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream Needed

linux-maguro
Launchpad, Ubuntu, Debian
Upstream Needed

linux-mako
Launchpad, Ubuntu, Debian
Upstream Needed

linux-manta
Launchpad, Ubuntu, Debian
Upstream Needed

linux-mvl-dove
Launchpad, Ubuntu, Debian
Upstream Needed

linux-oem
Launchpad, Ubuntu, Debian
Upstream Needed

linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream Needed

linux-raspi2
Launchpad, Ubuntu, Debian
Upstream Needed

linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream Needed

linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream Needed

Notes

AuthorNote
jdstrand
android kernels (flo, goldfish, grouper, maguro, mako and manta) are
not supported on the Ubuntu Touch 14.10 and earlier preview kernels
linux-lts-saucy no longer receives official support
linux-lts-quantal no longer receives official support

References

Bugs