CVE-2015-3217

Published: 13 December 2016

PCRE 7.8 and 8.32 through 8.37, and PCRE2 10.10 mishandle group empty matches, which might allow remote attackers to cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by /^(?:(?(1)\\.|([^\\\\W_])?)+)+$/.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
pcre3
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Notes

AuthorNote
seth-arnold
This might be disputed, Tavis says it is likely php misusing the
pcre3 API. I suspect allowing attackers to supply regular expressions is
always going to be a bad idea.
mdeslaur
upsteam bug says this is an issue with php, and are not going to
fix, so marking this as not-affected

References

Bugs