CVE-2015-3184

Published: 05 August 2015

mod_authz_svn in Apache Subversion 1.7.x before 1.7.21 and 1.8.x before 1.8.14, when using Apache httpd 2.4.x, does not properly restrict anonymous access, which allows remote anonymous users to read hidden files via the path name.

Priority

Medium

Status

Package Release Status
subversion
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.8.8-1ubuntu3.2])
Binaries built from this source package are in Universe and so are supported by the community.

Notes

AuthorNote
mdeslaur
only an issue with httpd 2.4. Needs to be built against httpd
updated with CVE-2015-3185 fix, and needs to be forced as the
security update didn't update the API version

References