CVE-2011-4862

Published: 25 December 2011

Buffer overflow in libtelnet/encrypt.c in telnetd in FreeBSD 7.3 through 9.0, MIT Kerberos Version 5 Applications (aka krb5-appl) 1.0.2 and earlier, Heimdal 1.5.1 and earlier, GNU inetutils, and possibly other products allows remote attackers to execute arbitrary code via a long encryption key, as exploited in the wild in December 2011.

Priority

Medium

Status

Package Release Status
heimdal
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6git20120311.dfsg.1-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.6git20120311.dfsg.1-2)
Patches:
Vendor: http://www.debian.org/security/2011/dsa-2372
Binaries built from this source package are in Universe and so are supported by the community.
inetutils
Launchpad, Ubuntu, Debian
Upstream
Released (1.9)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:1.8-6)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(2:1.8-6)
Patches:
Vendor: http://www.debian.org/security/2011/dsa-2373
krb5
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Vendor: http://www.debian.org/security/2011/dsa-2375
Binaries built from this source package are in Universe and so are supported by the community.
krb5-appl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Vendor: http://www.debian.org/security/2011/dsa-2375

Notes

AuthorNote
jdstrand
from DSA: "Kerberos support for telnetd contains a
pre-authentication buffer overflow".
did not check if this is protected via stack-protector yet
mdeslaur
all affected code is in universe binaries

References