Your submission was sent successfully! Close

CVE-2011-2896

Published: 19 August 2011

The LZW decompressor in the LWZReadByte function in giftoppm.c in the David Koblas GIF decoder in PBMPLUS, as used in the gif_read_lzw function in filter/image-gif.c in CUPS before 1.4.7, the LZWReadByte function in plug-ins/common/file-gif-load.c in GIMP 2.6.11 and earlier, the LZWReadByte function in img/gifread.c in XPCE in SWI-Prolog 5.10.4 and earlier, and other products, does not properly handle code words that are absent from the decompression table when encountered, which allows remote attackers to trigger an infinite loop or a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted compressed stream, a related issue to CVE-2006-1168 and CVE-2011-2895.

Priority

Medium

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.7)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.5.0-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.5.0-5)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.5.0-5)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.5.0-5)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.5.0-5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [1.5.0-5])
Patches:
Upstream: https://github.com/apple/cups/commit/771bd8cbffe1ffb06d90b2c7f00191830e6b738c
cupsys
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

gimp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.6.11-2ubuntu4)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.6.11-2ubuntu4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.6.11-2ubuntu4)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.6.11-2ubuntu4)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.6.11-2ubuntu4)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [2.6.11-2ubuntu4])
Patches:
Upstream: http://git.gnome.org/browse/gimp/commit/?id=376ad788c1a1c31d40f18494889c383f6909ebfc
Upstream: http://git.gnome.org/browse/gimp/commit/?id=b1a3de761362db982c0ddfaff60ab4a3c4267f32 (related)
swi-prolog
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Needed

Ubuntu 21.04 (Hirsute Hippo) Needed

Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: http://www.swi-prolog.org/git/packages/xpce.git/commit/bb328029beb148691edc031d9db9cf0a503c8247