CVE-2009-5155

Published: 26 February 2019

In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

Priority

Negligible

CVSS 3 base score: 7.5

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Needed

glibc
Launchpad, Ubuntu, Debian
Upstream
Released (2.28-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.29-0ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.29-0ubuntu2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=eb04c21373e2a2885f3d52ff192b0499afe3c672
gnulib
Launchpad, Ubuntu, Debian
Upstream
Released (20140202+stable-3.2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(20140202+stable-4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(20140202+stable-4)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=5513b40999149090987a0341c018d05d3eea1272