Your submission was sent successfully! Close

CVE-2009-5147

Published: 29 March 2017

DL::dlopen in Ruby 1.8, 1.9.0, 1.9.2, 1.9.3, 2.0.0 before patchlevel 648, and 2.1 before 2.1.8 opens libraries with tainted names.

Priority

Low

CVSS 3 base score: 7.3

Status

Package Release Status
ruby1.8
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/ruby/ruby/commit/4600cf725a86ce31266153647ae5aa1197b1215b (DL)
Upstream: https://github.com/ruby/ruby/commit/7269e3de3cee3bbb6ab77fc708f3a10cab00b65e (DL)
ruby1.9.1
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.9.3.484-2ubuntu1.3])
ruby2.0
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [ruby 1.x only])
ruby2.1
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

ruby2.2
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

ruby2.3
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(ruby 1.x only)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
seth-arnold
The Debian triage mentions two points, first that the upstream fix
has been dropped from upstream for unknown reasons; second, Fiddle in
Ruby 2.2 has the same problem.
MITRE hasn't (yet?) assigned a CVE for
7269e3de3cee3bbb6ab77fc708f3a10cab00b65e but that may be for their own
reasons.
mdeslaur
DL was removed in 2.2
This is the same issue as CVE-2015-7551, except only for 1.9.1

References