CVE-2009-1721

Published: 31 July 2009

The decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger a free of an uninitialized pointer.

Priority

Medium

Notes

AuthorNote
mdeslaur
vendor patch doesn't pass regression tests.
upstream patch is better and passes the tests.
for hardy, probably need to backport crasher fixes
http://cvs.savannah.gnu.org/viewvc/OpenEXR/IlmImf/ImfHuf.cpp?root=openexr&r1=1.6&r2=1.7
http://cvs.savannah.gnu.org/viewvc/OpenEXR/IlmImf/ImfHuf.cpp?root=openexr&r1=1.7&r2=1.8

References

Bugs