Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-0341

Published: 30 January 2023

A stack buffer overflow exists in the ec_glob function of editorconfig-core-c before v0.12.6 which allowed an attacker to arbitrarily write to the stack and possibly allows remote code execution. editorconfig-core-c v0.12.6 resolved this vulnerability by bound checking all write operations over the p_pcre buffer.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
editorconfig-core
Launchpad, Ubuntu, Debian
bionic
Released (0.12.1-1.1ubuntu0.18.04.1~esm1)
Available with Ubuntu Pro
focal
Released (0.12.1-1.1ubuntu0.20.04.1~esm1)
Available with Ubuntu Pro
jammy
Released (0.12.5-2ubuntu0.1~esm1)
Available with Ubuntu Pro
kinetic
Released (0.12.5-2.1ubuntu0.1)
trusty Ignored
(end of standard support)
upstream
Released (0.12.6-0.1)
xenial
Released (0.12.0-2ubuntu0.1~esm1)
Available with Ubuntu Pro
lunar Not vulnerable
(0.12.6-0.1)
mantic Not vulnerable
(0.12.6-0.1)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H