Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-21658

Published: 20 January 2022

Rust is a multi-paradigm, general-purpose programming language designed for performance and safety, especially safe concurrency. The Rust Security Response WG was notified that the `std::fs::remove_dir_all` standard library function is vulnerable a race condition enabling symlink following (CWE-363). An attacker could use this security issue to trick a privileged program into deleting files and directories the attacker couldn't otherwise access or delete. Rust 1.0.0 through Rust 1.58.0 is affected by this vulnerability with 1.58.1 containing a patch. Note that the following build targets don't have usable APIs to properly mitigate the attack, and are thus still vulnerable even with a patched toolchain: macOS before version 10.10 (Yosemite) and REDOX. We recommend everyone to update to Rust 1.58.1 as soon as possible, especially people developing programs expected to run in privileged contexts (including system daemons and setuid binaries), as those have the highest risk of being affected by this. Note that adding checks in your codebase before calling remove_dir_all will not mitigate the vulnerability, as they would also be vulnerable to race conditions like remove_dir_all itself. The existing mitigation is working as intended outside of race conditions.

Notes

AuthorNote
alexmurray
Will require any package in the Ubuntu archive which calls remove_dir_all() to be recompiled with the patched rustc

Priority

Medium

Cvss 3 Severity Score

6.3

Score breakdown

Status

Package Release Status
rustc
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(1.59.0+dfsg1~ubuntu1~llvm-1~ubuntu1~18.04.2)
focal
Released (1.59.0+dfsg1~ubuntu1~llvm-1~ubuntu1~20.04.2)
hirsute Ignored
(end of life)
impish Ignored
(end of life)
jammy Not vulnerable

kinetic Not vulnerable

lunar Not vulnerable

mantic Not vulnerable

noble Not vulnerable

trusty Needed

upstream
Released (1.58.1)
xenial Needed

Severity score breakdown

Parameter Value
Base score 6.3
Attack vector Local
Attack complexity High
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:H