CVE-2019-8696

Published: 14 August 2019

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.7-1ubuntu2.7)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.1.3-4ubuntu0.10)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/apple/cups/commit/2c030c7a06e0c2b8227c7e85f5c58dfb339731d0 (master)
Upstream: https://github.com/apple/cups/commit/f24e6cf6a39300ad0c3726a41a4aab51ad54c109 (2.2)