CVE-2019-3859

Published: 21 March 2019

An out of bounds read flaw was discovered in libssh2 before 1.8.1 in the _libssh2_packet_require and _libssh2_packet_requirev functions. A remote attacker who compromises a SSH server may be able to cause a Denial of Service or read data in the client memory.

From the Ubuntu security team

It was discovered that libssh2 incorrectly handled certain specially crafted packets. A remote attacker could possibly use this issue to cause a denial of service or obtain sensitive information.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
libssh2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.8.0-2.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.8.0-2.1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Notes

AuthorNote
msalvatore
Upstream fix causes regression:
https://lists.opensuse.org/opensuse-security-announce/2019-04/msg00102.html
Follow up patch: https://github.com/libssh2/libssh2/commit/ca2744483eac4e707084df5fc55cc69d57571dde

References