Your submission was sent successfully! Close

CVE-2019-20925

Published: 24 November 2020

An unauthenticated client can trigger denial of service by issuing specially crafted wire protocol messages, which cause the message decompressor to incorrectly allocate memory. This issue affects: MongoDB Inc. MongoDB Server v4.2 versions prior to 4.2.1; v4.0 versions prior to 4.0.13; v3.6 versions prior to 3.6.15; v3.4 versions prior to 3.4.24.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
mongodb
Launchpad, Ubuntu, Debian
Upstream
Released (3.6.15, 4.0.13, 4.2.1, 4.3.1, 3.4.24)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa)
Released (1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:3.6.3-0ubuntu1.4)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://github.com/mongodb/mongo/commit/c1a956e084d39e6da75cd347e63d0064ed9151a8