Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2016-9036

Published: 23 December 2016

An exploitable incorrect return value vulnerability exists in the mp_check function of Tarantool's Msgpuck library 1.0.3. A specially crafted packet can cause the mp_check function to incorrectly return success when trying to check if decoding a map16 packet will read outside the bounds of a buffer, resulting in a denial of service vulnerability.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
msgpuck
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic
Released (1.0.3-1.1)
cosmic
Released (1.0.3-1.1)
disco
Released (1.0.3-1.1)
eoan
Released (1.0.3-1.1)
focal
Released (1.0.3-1.1)
groovy
Released (1.0.3-1.1)
hirsute
Released (1.0.3-1.1)
impish
Released (1.0.3-1.1)
jammy
Released (1.0.3-1.1)
kinetic
Released (1.0.3-1.1)
lunar
Released (1.0.3-1.1)
mantic
Released (1.0.3-1.1)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Needed

yakkety Ignored
(end of life)
zesty Ignored
(end of life)
Patches:
upstream: https://github.com/rtsisyk/msgpuck/commit/d2c366e27eea4a5a24c6ec36ffcc4f4fd5b361ac
tarantool
Launchpad, Ubuntu, Debian
artful Not vulnerable
(1.7.2.385.g952d79e-1)
bionic Does not exist

cosmic Not vulnerable
(1.7.2.385.g952d79e-1)
disco Not vulnerable
(1.7.2.385.g952d79e-1)
eoan Not vulnerable
(1.7.2.385.g952d79e-1)
focal Not vulnerable
(1.7.2.385.g952d79e-1)
groovy Not vulnerable
(1.7.2.385.g952d79e-1)
hirsute Not vulnerable
(1.7.2.385.g952d79e-1)
impish Not vulnerable
(1.7.2.385.g952d79e-1)
jammy Not vulnerable
(1.7.2.385.g952d79e-1)
kinetic Not vulnerable
(1.7.2.385.g952d79e-1)
lunar Not vulnerable
(1.7.2.385.g952d79e-1)
mantic Not vulnerable
(1.7.2.385.g952d79e-1)
precise Not vulnerable

trusty Does not exist
(trusty was not-affected)
upstream
Released (1.7.2.385.g952d79e-1)
xenial Needed

yakkety Ignored
(end of life)
zesty Ignored
(end of life)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H