Your submission was sent successfully! Close

CVE-2016-4536

Published: 13 May 2016

The client in OpenAFS before 1.6.17 does not properly initialize the (1) AFSStoreStatus, (2) AFSStoreVolumeStatus, (3) VldbListByAttributes, and (4) ListAddrByAttributes structures, which might allow remote attackers to obtain sensitive memory information by leveraging access to RPC call traffic.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
openafs
Launchpad, Ubuntu, Debian
Upstream
Released (1.6.17-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.6.17-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.6.17-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.6.17-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.6.17-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://www.openafs.org/pages/security/openafs-sa-2016-002.patch
Upstream: https://www.openafs.org/pages/security/openafs-sa-2016-002-master.patch