Your submission was sent successfully! Close

CVE-2010-3091

Published: 29 September 2010

The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not verifying the openid.return_to value, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.

Priority

Medium

Status

Package Release Status
drupal6
Launchpad, Ubuntu, Debian
Upstream
Released (6.18-1, 6.16-1)
Patches:
Debdiff: https://bugs.launchpad.net/ubuntu/karmic/+source/drupal5/+bug/539056