Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

USN-5335-1: ImageMagick vulnerabilities

18 March 2022

Several security issues were fixed in ImageMagick.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

  • imagemagick - Image manipulation programs and library

Details

It was discovered that ImageMagick incorrectly handled certain values
when processing XPM image data or large images. If a user or automated
system using ImageMagick were tricked into opening a specially crafted
image, an attacker could exploit this to cause a denial of service or
possibly execute code with the privileges of the user invoking the program.
(CVE-2020-19667, CVE-2017-13144)

Suhwan Song discovered that ImageMagick incorrectly handled memory
when processing PNG,PALM,MIFF image data. If a user or automated system
using ImageMagick were tricked into opening a specially crafted image,
an attacker could exploit this to cause a denial of service or possibly
execute code with the privileges of the user invoking the program.
(CVE-2020-25664, CVE-2020-25665, CVE-2020-25674, CVE-2020-27753)

Suhwan Song discovered that ImageMagick incorrectly handled certain values
when processing image data. If a user or automated system using
ImageMagick were tricked into opening a specially crafted image, an
attacker could exploit this to cause a denial of service.
(CVE-2020-25676, CVE-2020-27750, CVE-2020-27760, CVE-2020-27762,
CVE-2020-27766, CVE-2020-27770)

Zhang Xiaohui discovered that ImageMagick incorrectly handled certain values
when processing image data. If a user or automated system using
ImageMagick were tricked into opening a specially crafted image, an
attacker could exploit this to cause a denial of service.
(CVE-2021-20176, CVE-2021-20241, CVE-2021-20243)

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-3681-1: libmagickwand-6.q16-3, libmagickwand-6.q16-dev, libmagick++5, libmagickcore-6.q16-2, libmagickcore-dev, libmagickcore-6.q16-3-extra, imagemagick-doc, libmagickcore5-extra, libimage-magick-q16hdri-perl, libmagick++-6.q16-5v5, libmagickcore-6-headers, libmagick++-6.q16-7, libmagickcore-6-arch-config, imagemagick-6-common, libmagick++-6.q16-dev, libmagickcore-6.q16-dev, libmagickwand-6-headers, perlmagick, libmagickcore-6.q16hdri-3, libmagickcore-6.q16hdri-dev, libmagick++-6-headers, libimage-magick-perl, libimage-magick-q16-perl, imagemagick, libmagickcore-6.q16-2-extra, libmagick++-dev, libmagick++-6.q16hdri-7, libmagickwand-6.q16hdri-dev, libmagickcore-6.q16hdri-3-extra, imagemagick-6.q16hdri, libmagick++-6.q16hdri-dev, libmagickwand-6.q16-2, imagemagick-6-doc, libmagickwand5, imagemagick-common, libmagickcore5, libmagickwand-dev, libmagickwand-6.q16hdri-3, imagemagick-6.q16, libmagickcore-6.q16-3
  • USN-5736-1: libmagickwand-6.q16-3, libmagickwand-6.q16-dev, libmagick++5, libmagickcore-6.q16-2, libmagickcore-dev, libmagickcore-6.q16-6, libmagickcore-6.q16-6-extra, libmagick++-6.q16hdri-8, libmagickcore-6.q16-3-extra, imagemagick-doc, libmagickcore5-extra, libimage-magick-q16hdri-perl, libmagickcore-6.q16hdri-6-extra, libmagick++-6.q16-5v5, libmagickcore-6-headers, libmagick++-6.q16-7, libmagick++-6.q16-8, libmagickcore-6-arch-config, imagemagick-6-common, libmagick++-6.q16-dev, libmagickcore-6.q16-dev, libmagickwand-6-headers, perlmagick, libmagickcore-6.q16hdri-3, libmagickcore-6.q16hdri-dev, libmagick++-6-headers, libmagickwand-6.q16-6, libimage-magick-perl, libimage-magick-q16-perl, imagemagick, libmagickcore-6.q16-2-extra, libmagick++-dev, libmagick++-6.q16hdri-7, libmagickwand-6.q16hdri-dev, libmagickcore-6.q16hdri-3-extra, imagemagick-6.q16hdri, libmagick++-6.q16hdri-dev, libmagickcore-6.q16hdri-6, imagemagick-6-doc, libmagickwand-6.q16-2, libmagickwand-6.q16hdri-6, imagemagick-common, libmagickcore5, libmagickwand5, libmagickwand-dev, libmagickwand-6.q16hdri-3, imagemagick-6.q16, libmagickcore-6.q16-3
  • USN-5736-2: libmagickwand-6.q16-dev, libmagickcore-dev, libmagickcore-6.q16-6, libmagickcore-6.q16-6-extra, libmagick++-6.q16hdri-8, imagemagick-doc, libimage-magick-q16hdri-perl, libmagickcore-6.q16hdri-6-extra, libmagickcore-6-headers, libmagick++-6.q16-8, libmagickcore-6-arch-config, imagemagick-6-common, libmagick++-6.q16-dev, libmagickcore-6.q16-dev, libmagickwand-6-headers, perlmagick, libmagickcore-6.q16hdri-dev, libmagick++-6-headers, libmagickwand-6.q16-6, libimage-magick-perl, libimage-magick-q16-perl, imagemagick, libmagick++-dev, libmagickwand-6.q16hdri-dev, imagemagick-6.q16hdri, libmagick++-6.q16hdri-dev, libmagickcore-6.q16hdri-6, imagemagick-6-doc, libmagickwand-6.q16hdri-6, imagemagick-common, libmagickwand-dev, imagemagick-6.q16
  • USN-6200-1: libmagickwand-6.q16-3, libmagickwand-6.q16-dev, libmagickcore-6.q16-2, libmagickcore-dev, libmagickcore-6.q16-6, libmagickcore-6.q16-6-extra, libmagick++-6.q16hdri-8, libmagickcore-6.q16-3-extra, imagemagick-doc, libimage-magick-q16hdri-perl, libmagickcore-6.q16hdri-6-extra, libmagick++-6.q16-5v5, libmagickcore-6-headers, libmagick++-6.q16-7, libmagick++-6.q16-8, libmagickcore-6-arch-config, imagemagick-6-common, libmagick++-6.q16-dev, libmagickcore-6.q16-dev, libmagickwand-6-headers, perlmagick, libmagickcore-6.q16hdri-3, libmagickcore-6.q16hdri-dev, libmagick++-6-headers, libmagickwand-6.q16-6, libimage-magick-perl, libimage-magick-q16-perl, imagemagick, libmagickcore-6.q16-2-extra, libmagick++-dev, libmagick++-6.q16hdri-7, libmagickwand-6.q16hdri-dev, libmagickcore-6.q16hdri-3-extra, imagemagick-6.q16hdri, libmagick++-6.q16hdri-dev, libmagickcore-6.q16hdri-6, imagemagick-6-doc, libmagickwand-6.q16-2, libmagickwand-6.q16hdri-6, imagemagick-common, libmagickwand-dev, libmagickwand-6.q16hdri-3, imagemagick-6.q16, libmagickcore-6.q16-3
  • USN-4988-1: libmagickwand-6.q16-3, libmagickwand-6.q16-dev, libmagickcore-dev, libmagickcore-6.q16-6, libmagickcore-6.q16-6-extra, libmagick++-6.q16hdri-8, libmagickcore-6.q16-3-extra, imagemagick-doc, libimage-magick-q16hdri-perl, libmagickcore-6.q16hdri-6-extra, libmagickcore-6-headers, libmagick++-6.q16-7, libmagick++-6.q16-8, libmagickcore-6-arch-config, imagemagick-6-common, libmagick++-6.q16-dev, libmagickcore-6.q16-dev, libmagickwand-6-headers, perlmagick, libmagickcore-6.q16hdri-3, libmagickcore-6.q16hdri-dev, libmagick++-6-headers, libmagickwand-6.q16-6, libimage-magick-perl, libimage-magick-q16-perl, imagemagick, libmagick++-dev, libmagick++-6.q16hdri-7, libmagickwand-6.q16hdri-dev, libmagickcore-6.q16hdri-3-extra, imagemagick-6.q16hdri, libmagick++-6.q16hdri-dev, libmagickcore-6.q16hdri-6, imagemagick-6-doc, libmagickwand-6.q16hdri-6, imagemagick-common, libmagickwand-dev, libmagickwand-6.q16hdri-3, imagemagick-6.q16, libmagickcore-6.q16-3