Your submission was sent successfully! Close

CVE-2020-27750

Published: 8 December 2020

A flaw was found in ImageMagick in MagickCore/colorspace-private.h and MagickCore/quantum.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type `unsigned char` and math division by zero. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-68.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
bionic
Released (8:6.9.7.4+dfsg-16ubuntu6.11)
focal
Released (8:6.9.10.23+dfsg-2.1ubuntu11.4)
groovy
Released (8:6.9.10.23+dfsg-2.1ubuntu13.3)
hirsute Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
impish Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
jammy Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
precise Does not exist

trusty Does not exist

upstream
Released (8:6.9.11.24+dfsg-1)
xenial
Released (8:6.8.9.9-7ubuntu5.16+esm2)