Your submission was sent successfully! Close

USN-4582-1: Vim vulnerabilities

14 October 2020

Several security issues were fixed in Vim.

Releases

Packages

  • vim - Vi IMproved - enhanced vi editor

Details

It was discovered that Vim incorrectly handled permissions on the .swp
file. A local attacker could possibly use this issue to obtain sensitive
information. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-17087)

It was discovered that Vim incorrectly handled restricted mode. A local
attacker could possibly use this issue to bypass restricted mode and
execute arbitrary commands. Note: This update only makes executing shell
commands more difficult. Restricted mode should not be considered a
complete security measure. (CVE-2019-20807)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5147-1: vim, vim-gtk, vim-nox-py2, vim-athena-py2, vim-athena, vim-gtk-py2, vim-gui-common, vim-common, vim-runtime, vim-tiny, vim-gnome-py2, vim-gtk3-py2, vim-lesstif, vim-gnome, vim-gtk3, xxd, vim-nox, vim-doc