USN-3653-1: Linux kernel vulnerabilities

22 May 2018

Several security issues were addressed in the Linux kernel.

Releases

Packages

  • linux - Linux kernel

Details

Jann Horn and Ken Johnson discovered that microprocessors utilizing
speculative execution of a memory read may allow unauthorized memory
reads via a sidechannel attack. This flaw is known as Spectre
Variant 4. A local attacker could use this to expose sensitive
information, including kernel memory. (CVE-2018-3639)

It was discovered that the netlink subsystem in the Linux kernel did not
properly restrict observations of netlink messages to the appropriate net
namespace. A local attacker could use this to expose sensitive information
(kernel netlink traffic). (CVE-2017-17449)

Tuba Yavuz discovered that a double-free error existed in the USBTV007
driver of the Linux kernel. A local attacker could use this to cause a
denial of service (system crash) or possibly execute arbitrary code.
(CVE-2017-17975)

It was discovered that a race condition existed in the Device Mapper
component of the Linux kernel. A local attacker could use this to cause a
denial of service (system crash). (CVE-2017-18203)

It was discovered that an infinite loop could occur in the madvise(2)
implementation in the Linux kernel in certain circumstances. A local
attacker could use this to cause a denial of service (system hang).
(CVE-2017-18208)

Silvio Cesare discovered a buffer overwrite existed in the NCPFS
implementation in the Linux kernel. A remote attacker controlling a
malicious NCPFS server could use this to cause a denial of service (system
crash) or possibly execute arbitrary code. (CVE-2018-8822)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10

Please note that fully mitigating CVE-2018-3639 (Spectre Variant 4)
may require corresponding processor microcode/firmware updates or,
in virtual environments, hypervisor updates. On i386 and amd64
architectures, the SSBD feature is required to enable the kernel
mitigations. BIOS vendors will be making updates available for Intel
processors that implement SSBD and Ubuntu is working with Intel to
provide future microcode updates. Ubuntu users with a processor from
a different vendor should contact the vendor to identify necessary
firmware updates. Ubuntu provided corresponding QEMU updates for users
of self-hosted virtual environments in USN 3651-1. Ubuntu users in
cloud environments should contact the cloud provider to confirm that
the hypervisor has been updated to expose the new CPU features to
virtual machines.

Related notices

  • USN-3654-1: linux-image-4.4.0-127-powerpc64-smp, linux, linux-image-4.4.0-127-lowlatency, linux-image-powerpc-e500mc, linux-aws, linux-image-4.4.0-127-powerpc64-emb, linux-image-4.4.0-127-powerpc-e500mc, linux-image-powerpc64-smp, linux-image-kvm, linux-image-4.4.0-127-powerpc-smp, linux-image-powerpc64-emb, linux-image-lowlatency, linux-image-generic, linux-kvm, linux-image-4.4.0-127-generic-lpae, linux-image-4.4.0-127-generic, linux-image-powerpc-smp, linux-image-generic-lpae, linux-image-aws, linux-image-4.4.0-1026-kvm, linux-image-4.4.0-1060-aws
  • USN-3756-1: intel-microcode
  • USN-3654-2: linux-image-4.4.0-127-powerpc64-smp, linux-image-4.4.0-127-powerpc-e500mc, linux-image-powerpc64-emb-lts-xenial, linux-image-4.4.0-127-generic-lpae, linux-lts-xenial, linux-image-lowlatency-lts-xenial, linux-image-4.4.0-127-generic, linux-image-4.4.0-127-lowlatency, linux-image-generic-lts-xenial, linux-image-powerpc-e500mc-lts-xenial, linux-image-4.4.0-127-powerpc-smp, linux-image-4.4.0-1022-aws, linux-aws, linux-image-generic-lpae-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-aws, linux-image-powerpc-smp-lts-xenial, linux-image-4.4.0-127-powerpc64-emb
  • USN-3680-1: libvirt-bin, libvirt0, libvirt
  • USN-3655-1: linux-image-powerpc-e500, linux-image-3.13.0-149-generic-lpae, linux-image-powerpc64-smp, linux, linux-image-3.13.0-149-powerpc-e500mc, linux-image-3.13.0-149-powerpc-smp, linux-image-lowlatency, linux-image-powerpc-e500mc, linux-image-powerpc-smp, linux-image-generic, linux-image-powerpc64-emb, linux-image-3.13.0-149-powerpc-e500, linux-image-generic-lpae, linux-image-3.13.0-149-generic, linux-image-3.13.0-149-powerpc64-smp, linux-image-3.13.0-149-lowlatency, linux-image-3.13.0-149-powerpc64-emb
  • USN-3679-1: qemu, qemu-system, qemu-system-x86
  • USN-3653-2: linux-image-4.13.0-43-generic-lpae, linux-image-gke, linux-image-oem, linux-image-4.13.0-1028-oem, linux-image-4.13.0-43-generic, linux-image-gcp, linux-image-generic-lpae-hwe-16.04, linux-gcp, linux-image-4.13.0-1017-gcp, linux-image-generic-hwe-16.04, linux-hwe, linux-azure, linux-image-lowlatency-hwe-16.04, linux-oem, linux-image-4.13.0-43-lowlatency, linux-image-azure, linux-image-4.13.0-1018-azure
  • USN-3777-3: linux-image-azure, linux-image-4.15.0-1025-azure, linux-azure
  • USN-3619-2: linux-image-4.4.0-1016-aws, linux-image-4.4.0-119-lowlatency, linux-image-powerpc64-emb-lts-xenial, linux-lts-xenial, linux-image-4.4.0-119-powerpc-e500mc, linux-image-lowlatency-lts-xenial, linux-image-generic-lts-xenial, linux-image-powerpc-e500mc-lts-xenial, linux-image-4.4.0-119-powerpc64-smp, linux-image-4.4.0-119-powerpc-smp, linux-image-4.4.0-119-generic, linux-image-4.4.0-119-generic-lpae, linux-image-4.4.0-119-powerpc64-emb, linux-aws, linux-image-generic-lpae-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-aws, linux-image-powerpc-smp-lts-xenial
  • USN-3656-1: linux-snapdragon, linux-raspi2, linux-image-raspi2, linux-image-snapdragon, linux-image-4.4.0-1090-raspi2, linux-image-4.4.0-1093-snapdragon
  • USN-3652-1: linux, linux-image-gcp, linux-gcp, linux-aws, linux-image-4.15.0-22-generic, linux-azure, linux-image-kvm, linux-oem, linux-image-4.15.0-22-generic-lpae, linux-image-gke, linux-image-lowlatency, linux-image-generic, linux-kvm, linux-image-4.15.0-1009-aws, linux-image-azure-edge, linux-image-4.15.0-1008-gcp, linux-image-4.15.0-22-lowlatency, linux-image-4.15.0-1010-kvm, linux-image-azure, linux-image-generic-lpae, linux-image-aws, linux-image-oem
  • USN-3655-2: linux-lts-trusty, linux-image-3.13.0-149-generic-lpae, linux-image-generic-lpae-lts-trusty, linux-image-generic-lts-trusty, linux-image-3.13.0-149-generic
  • USN-3657-1: linux-image-4.13.0-1020-raspi2, linux-image-raspi2, linux-raspi2
  • USN-3651-1: qemu, qemu-system, qemu-system-x86
  • USN-3619-1: linux, linux-image-4.4.0-1088-snapdragon, linux-image-powerpc-e500mc, linux-image-4.4.0-119-generic, linux-aws, linux-image-raspi2, linux-snapdragon, linux-image-powerpc64-smp, linux-image-4.4.0-119-powerpc-e500mc, linux-image-kvm, linux-image-4.4.0-119-generic-lpae, linux-image-powerpc64-emb, linux-image-4.4.0-119-powerpc64-emb, linux-image-lowlatency, linux-image-generic, linux-image-4.4.0-1054-aws, linux-kvm, linux-image-4.4.0-119-lowlatency, linux-image-powerpc-smp, linux-image-snapdragon, linux-image-generic-lpae, linux-image-aws, linux-image-4.4.0-1020-kvm, linux-image-4.4.0-1086-raspi2, linux-raspi2, linux-image-4.4.0-119-powerpc64-smp, linux-image-4.4.0-119-powerpc-smp