CVE-2020-25710

Published: 13 November 2020

A flaw was found in OpenLDAP in versions before 2.4.56. This flaw allows an attacker who sends a malicious packet processed by OpenLDAP to force a failed assertion in csnNormalize23(). The highest threat from this vulnerability is to system availability.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
openldap
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.56+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla)
Released (2.4.53+dfsg-1ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.4.49+dfsg-2ubuntu1.5)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.45+dfsg-1ubuntu1.8)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.4.42+dfsg-2ubuntu3.11)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.4.31-1+nmu2ubuntu8.5+esm4)
Patches:
Upstream: https://git.openldap.org/openldap/openldap/-/commit/bdb0d459187522a6063df13871b82ba8dcc6efe2