Your submission was sent successfully! Close

USN-5670-1: .NET 6 vulnerability

11 October 2022

.NET 6 could be made to execute arbitrary code.

Releases

Packages

  • dotnet6 - dotNET CLI tools and runtime

Details

Edward Thomson discovered that .NET 6 incorrectly handled
permissions for local NuGet cache. A local attacker could
possibly use this issue to execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04

In general, a standard system update will make all the necessary changes.

References