USN-3902-1: PHP vulnerabilities

06 March 2019

Several security issues were fixed in PHP.

Releases

Packages

  • php5 - HTML-embedded scripting language interpreter
  • php7.0 - HTML-embedded scripting language interpreter

Details

It was discovered that the PHP XML-RPC module incorrectly handled decoding
XML data. A remote attacker could possibly use this issue to cause PHP to
crash, resulting in a denial of service. (CVE-2019-9020, CVE-2019-9024)

It was discovered that the PHP PHAR module incorrectly handled certain
filenames. A remote attacker could possibly use this issue to cause PHP to
crash, resulting in a denial of service. (CVE-2019-9021)

It was discovered that PHP incorrectly parsed certain DNS responses. A
remote attacker could possibly use this issue to cause PHP to crash,
resulting in a denial of service. This issue only affected Ubuntu 16.04
LTS. (CVE-2019-9022)

It was discovered that PHP incorrectly handled mbstring regular
expressions. A remote attacker could possibly use this issue to cause PHP
to crash, resulting in a denial of service. (CVE-2019-9023)

Related notices

  • USN-3922-2: php5-gd, php5-fpm, php5-xmlrpc, php5, php5-dev, php5-ldap, php-pear, php5-enchant, php5-recode, php5-cgi, php5-sqlite, libapache2-mod-php5, php5-cli, php5-tidy, php5-gmp, php5-intl, php5-curl, php5-xsl, php5-readline, libapache2-mod-php5filter, php5-common, php5-odbc, libphp5-embed, php5-snmp, php5-mysqlnd, php5-sybase, php5-pgsql, php5-mysql, php5-pspell
  • USN-3902-2: php5-cgi, php5-fpm, php5-xmlrpc, php5, libapache2-mod-php5, php5-cli
  • USN-3922-3: php5-cgi, php5-fpm, php5-xmlrpc, php5, libapache2-mod-php5, php5-cli