Your submission was sent successfully! Close

CVE-2019-9023

Published: 22 February 2019

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regexec.c, ext/mbstring/oniguruma/regparse.c, ext/mbstring/oniguruma/enc/unicode.c, and ext/mbstring/oniguruma/src/utf32_be.c when a multibyte regular expression pattern contains invalid multibyte sequences.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise
Released (5.3.10-1ubuntu3.33)
trusty
Released (5.5.9+dfsg-1ubuntu4.27)
upstream Needs triage

xenial Does not exist

php7.0
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial
Released (7.0.33-0ubuntu0.16.04.2)
php7.2
Launchpad, Ubuntu, Debian
bionic
Released (7.2.15-0ubuntu0.18.04.1)
cosmic
Released (7.2.15-0ubuntu0.18.10.1)
precise Does not exist

trusty Does not exist

upstream
Released (7.2.14)
xenial Does not exist

php7.3
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (7.3.1)
xenial Does not exist