USN-376-1: imlib2 vulnerabilities

03 November 2006

imlib2 vulnerabilities

Releases

Details

M. Joonas Pihlaja discovered that imlib2 did not sufficiently verify the
validity of ARGB, JPG, LBM, PNG, PNM, TGA, and TIFF images. If a user
were tricked into viewing or processing a specially crafted image with
an application that uses imlib2, the flaws could be exploited to execute
arbitrary code with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
  • libimlib2 - 1.2.1-2ubuntu1.1
Ubuntu 6.06
  • libimlib2 - 1.2.1-2ubuntu0.1
Ubuntu 5.10
  • libimlib2 - 1.2.0-2.2ubuntu2.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.