USN-3633-1: Linux kernel (Intel Euclid) vulnerability

24 April 2018

The system could be made to crash or run programs as an administrator.

Releases

Packages

Details

Jann Horn discovered that the Berkeley Packet Filter (BPF) implementation
in the Linux kernel improperly performed sign extension in some situations.
A local attacker could use this to cause a denial of service (system crash)
or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References

Related notices

  • USN-3523-1: linux-image-generic, linux-image-lowlatency, linux-image-4.13.0-25-generic, linux-image-4.13.0-25-lowlatency, linux
  • USN-3523-2: linux-hwe, linux-image-generic-hwe-16.04, linux-image-oem, linux-image-gke, linux-image-generic-lpae-hwe-16.04, linux-image-4.13.0-1015-oem, linux-gcp, linux-image-4.13.0-26-lowlatency, linux-image-azure, linux-image-gcp, linux-image-4.13.0-1005-azure, linux-azure, linux-image-4.13.0-26-generic-lpae, linux-image-lowlatency-hwe-16.04, linux-oem, linux-image-4.13.0-1006-gcp, linux-image-4.13.0-26-generic
  • USN-3523-3: linux-image-4.13.0-1011-raspi2, linux-image-raspi2, linux-raspi2
  • USN-3619-1: linux-kvm, linux-aws, linux-image-generic-lpae, linux-image-powerpc-e500mc, linux, linux-image-powerpc64-emb, linux-image-generic, linux-image-4.4.0-1088-snapdragon, linux-image-powerpc64-smp, linux-image-snapdragon, linux-image-4.4.0-119-generic, linux-image-aws, linux-image-lowlatency, linux-image-raspi2, linux-image-4.4.0-1020-kvm, linux-image-powerpc-smp, linux-image-4.4.0-119-lowlatency, linux-image-4.4.0-119-powerpc64-smp, linux-snapdragon, linux-image-4.4.0-1086-raspi2, linux-image-kvm, linux-raspi2, linux-image-4.4.0-1054-aws, linux-image-4.4.0-119-powerpc64-emb, linux-image-4.4.0-119-powerpc-smp, linux-image-4.4.0-119-powerpc-e500mc, linux-image-4.4.0-119-generic-lpae
  • USN-3619-2: linux-image-powerpc-smp-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-generic-lts-xenial, linux-image-4.4.0-1016-aws, linux-image-4.4.0-119-powerpc64-emb, linux-image-powerpc-e500mc-lts-xenial, linux-aws, linux-image-4.4.0-119-powerpc-smp, linux-image-4.4.0-119-generic, linux-image-4.4.0-119-lowlatency, linux-image-aws, linux-image-powerpc64-emb-lts-xenial, linux-image-4.4.0-119-powerpc64-smp, linux-image-generic-lpae-lts-xenial, linux-image-4.4.0-119-powerpc-e500mc, linux-lts-xenial, linux-image-lowlatency-lts-xenial, linux-image-4.4.0-119-generic-lpae