USN-3454-1: libffi vulnerability

12 October 2017

A security issue was fixed in libffi.

Releases

Packages

  • libffi - Foreign Function Interface library

Details

It was discovered that libffi incorrectly enforced an executable stack. An
attacker could possibly use this issue, in combination with another
vulnerability, to facilitate executing arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

References

Related notices