Your submission was sent successfully! Close

CVE-2017-1000376

Published: 19 June 2017

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Priority

Medium

CVSS 3 base score: 7.0

Status

Package Release Status
libffi
Launchpad, Ubuntu, Debian
Upstream
Released (3.2.1-4)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr)
Released (3.1~rc1+r3.0.13-12ubuntu0.2)
Patches:
Upstream: https://github.com/libffi/libffi/commit/978c9540154d320525488db1b7049277122f736d